<!DOCTYPE html>
<html>
  
    <!doctype html>
    <html>
    <head>
        <title data-react-helmet="true">Stanley Engen Obituary (1922 - 2021) - Caledonia, Mn, MN - La Crosse Tribune</title>
        <meta data-react-helmet="true" key="description" name="description" content="Stanley A. Engen CALEDONIA - Stanley A. Engen, age 99, of Caledonia, passed away December 11, 2021 at Northgate Care Center, Waukon, Iowa. Services will be at 11:00 a.m., Thursday, December 23, 2021, "/><meta data-react-helmet="true" property="og:url" content="https://www.legacy.com/us/obituaries/lacrossetribune/name/stanley-engen-obituary?id=31865059"/><meta data-react-helmet="true" property="og:title" content="Stanley A. Engen Obituary (1922 - 2021) La Crosse Tribune"/><meta data-react-helmet="true" property="og:description" content="View Stanley A. Engen&#x27;s obituary, send flowers and sign the guestbook."/><meta data-react-helmet="true" property="og:site_name" content="Legacy.com"/><meta data-react-helmet="true" property="fb:admins" content="100001241414690"/><meta data-react-helmet="true" property="fb:app_id" content="162166070516109"/><meta data-react-helmet="true" property="fb:pages" content="54460902620"/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" property="og:image" content="https://cache.legacy.net/globalcontent/funeralhomelogos/spotlightimage/spotlight_candle.jpgx?w=600&amp;h=315&amp;option=0"/><meta data-react-helmet="true" property="og:image:secure_url" content="https://cache.legacy.net/globalcontent/funeralhomelogos/spotlightimage/spotlight_candle.jpgx?w=600&amp;h=315&amp;option=0"/><meta data-react-helmet="true" property="og:image:height" content="315"/><meta data-react-helmet="true" property="og:image:width" content="600"/><meta data-react-helmet="true" content="width=device-width, initial-scale=1, maximum-scale=1" name="viewport"/>
        <link data-react-helmet="true" rel="canonical" href="https://www.legacy.com/us/obituaries/lacrossetribune/name/stanley-engen-obituary?id=31865059"/><link data-react-helmet="true" href="https://fonts.googleapis.com/css2?family=Open+Sans:ital,wght@0,400;0,700;1,400;1,700&amp;family=PT+Serif:ital,wght@0,400;0,700;1,400;1,700&amp;display=swap" rel="stylesheet"/>
        
        <script data-react-helmet="true" src="https://hello.pledge.to/assets/widget.js" id="plg-widget" async="async"></script><script data-react-helmet="true" src="https://tagan.adlightning.com/legacy/op.js" defer="true"></script><script data-react-helmet="true" type="text/javascript">var dataLayer = [];
dataLayer.push({'Affiliate': 'lacrossetribune'});
dataLayer.push({'AnalyticPageCategory': 'premium_obit'});
dataLayer.push({'FHID': '21121'});
dataLayer.push({'FirstToFile': 'offshore_partner'});
dataLayer.push({'GBID': '200853248'});
dataLayer.push({'MergedObitParents': 'Paid_NP-Offshore'});
dataLayer.push({'NoticeType': 'premium'});
dataLayer.push({'ObitDaysActive': '102'});
dataLayer.push({'ObitPublishDate': '12/19/2021'});
dataLayer.push({'PageName': 'obit-premium'});
dataLayer.push({'PersonID': '200853248'});
dataLayer.push({'ProductName': 'obit-aff'});
dataLayer.push({'ViewportDimension': (() => {
    const width = Math.max(document.documentElement.clientWidth, window.innerWidth || 0);
    const height = Math.max(document.documentElement.clientHeight, window.innerHeight || 0);
    const dimensions = width + 'x' + height;
    return dimensions;
  })()});</script><script data-react-helmet="true" >(function (w, d, s, l, i) {
                  w[l] = w[l] || []; w[l].push({
                      'gtm.start':
                          new Date().getTime(), event: 'gtm.js'
                  }); var f = d.getElementsByTagName(s)[0],
                          j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : ''; j.async = true; j.src =
                              '//www.googletagmanager.com/gtm.js?id=' + i + dl; f.parentNode.insertBefore(j, f);
                })(window, document, 'script', 'dataLayer', 'GTM-TDQHZW');</script><script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org","@type":"Person","additionalName":"A.","address":{"@type":"PostalAddress","addressCountry":"United States","addressLocality":"Caledonia","addressRegion":"Mn","postalCode":"55921"},"birthDate":"1922-10-18","deathDate":"2021-12-11","familyName":"Engen","givenName":"Stanley","name":"Stanley A. Engen"}</script><script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org","@type":"LocalBusiness","address":{"@type":"PostalAddress","addressCountry":"US","addressLocality":"Caledonia","addressRegion":"MN","postalCode":"55921","streetAddress":"205 E Main St"},"name":"McCormick Funeral Home","telephone":"(507) 725-2616"}</script><script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org","@type":"NewsArticle","articleBody":"Stanley A. Engen CALEDONIA - Stanley A. Engen, age 99, of Caledonia, passed away December 11, 2021 at Northgate Care Center, Waukon, Iowa. Services will be at 11:00 a.m., Thursday, December 23, 2021, at Immanuel Lutheran Church, Caledonia. Visitation will be from 4:00 p.m. to 7:00 p.m., Wednesday, December 22, 2021, at the church, and also one hour prior to the service on Thursday. A full obituary will be in next week's paper. McCormick Funeral Home, Caledonia is assisting the family. Onlinecondolences may be given mccormickfuneralhome.net","articleSection":"Obituaries","author":[{"@type":"Person","name":"Legacy"}],"creator":"Legacy.com","dateCreated":"2021-12-19T00:00:00.000Z","dateModified":"2021-12-19T00:00:00.000Z","datePublished":"2021-12-19T00:00:00.000Z","description":"Stanley A. Engen CALEDONIA - Stanley A. Engen, age 99, of Caledonia, passed away December 11, 2021 at Northgate Care Center, Waukon, Iowa. Services will be at 11:00 a.m., Thursday, December 23, 2021, ","genre":"Obituary(Obit), Biography","headline":"Stanley Engen Obituary (1922 - 2021) - Caledonia, Mn, MN - La Crosse Tribune","keywords":"Stanley A. Engen, Obituaries","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.legacy.com/us/obituaries/lacrossetribune/name/stanley-engen-obituary?id=31865059"},"publisher":{"@type":"Organization","name":"Legacy","logo":{"@type":"ImageObject","height":60,"url":"https://cache.legacy.net/globalcontent/affiliatelogosgbmobile/legacy.pngx?w=244&h=60&option=1","width":244}},"url":"https://www.legacy.com/us/obituaries/lacrossetribune/name/stanley-engen-obituary?id=31865059"}</script><script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org","@type":"Event","description":"Funeral and Services for Stanley A. Engen","endDate":"2021-12-22T19:00:00.000Z","location":{"@type":"Place","address":{"@type":"PostalAddress","addressCountry":"United States","addressLocality":"Caledonia","addressRegion":"MN"},"description":"Funeral and Services for Stanley A. Engen","name":"Immanuel Lutheran Church"},"name":"Visitation for Stanley A. Engen","startDate":"2021-12-22T16:00:00.000Z"}</script><script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org","@type":"Event","description":"Funeral and Services for Stanley A. Engen","endDate":"2021-12-23T11:00:00.000Z","location":{"@type":"Place","address":{"@type":"PostalAddress","addressCountry":"United States","addressLocality":"Caledonia","addressRegion":"MN"},"description":"Funeral and Services for Stanley A. Engen","name":"Immanuel Lutheran Church"},"name":"Visitation for Stanley A. Engen","startDate":"2021-12-23T10:00:00.000Z"}</script><script data-react-helmet="true" type="application/ld+json">{"@context":"http://schema.org","@type":"Event","description":"Funeral and Services for Stanley A. Engen","location":{"@type":"Place","address":{"@type":"PostalAddress","addressCountry":"United States","addressLocality":"Caledonia","addressRegion":"MN"},"description":"Funeral and Services for Stanley A. Engen","name":"Immanuel Lutheran Church"},"name":"Service for Stanley A. Engen","startDate":"2021-12-23T11:00:00.000Z"}</script><script data-react-helmet="true" >(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-TDWDC2');</script><script data-react-helmet="true" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" type="text/javascript" async="true"></script><script data-react-helmet="true" >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</script><script data-react-helmet="true" type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://carpentercomparison.com/v2nlfZdn3WoydGB1vjUETH1FnPIs9s3tfOmWUoMQxerMX82X2Uytr4JrrHDfUxs_v",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");</script><script data-react-helmet="true" >
    const callbackRevealSimple = (mutationsList, observer) => {
      const revealAd = document.getElementById('reveal-ad-1');
      if (revealAd === null) {
        observer.disconnect();
        return null;
      }
      for(const mutation of mutationsList) {
        if (mutation.type === 'childList') {
          const revealSimpleElement = document.getElementById('x-reveal-simple');
          if (revealSimpleElement) {
            revealSimpleControl();
            observer.disconnect();
          }
        }
      }
    };

    const revealSimpleControl = () => {
      const revealSimpleElement = document.getElementById('x-reveal-simple');
      if (revealSimpleElement === null) {
        return null;
      }
      const revealad1Listener = (e) => {
        initialHeight = revealSimpleElement.offsetHeight;
        scrollHeight = initialHeight - window.pageYOffset/2;

        revealSimpleElement.style.maxHeight = scrollHeight + 'px';
        revealSimpleElement.classList.remove('expand');

        if (scrollHeight <= 10) {
          window.removeEventListener('scroll', revealad1Listener);
          revealSimpleElement.style.display = 'none';
          }
      };

      window.addEventListener('scroll', revealad1Listener);
    };

    window.addEventListener('load', () => {
      const observer = new MutationObserver(callbackRevealSimple);
      observer.observe(document.body, { childList: true });
    });</script>
        <style data-react-helmet="true" type="text/css">
          @font-face
          {
            font-family: 'webfontaeGm';
            src: url('https://get.fontspace.co/webfont/aeGm/ODA5ZTc3MjA5ZWU4NDg2MjhiZjNjNWJkZDFhOWIyZjMudHRm/old-sport-01-college-ncv.woff') format('woff');
          }
          </style>
        <style data-styled="true" data-styled-version="5.1.1">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</style>
    </head>
    <div data-hypernova-key="ObituaryPage" data-hypernova-id="d812ce1f-bdd3-4196-b0e0-296a5ef0bdd7"><script>window.aax = window.aax || {};
window.aax.cmd = window.aax.cmd || [];
window.aax.cmd.push(function () {
  if (window.aax.getAbpStatus()) {
      window.googletag = window.googletag || {};
      window.googletag.cmd = window.googletag.cmd || [];
      window.googletag.cmd.push(function () {
          googletag.pubads().refresh();
      });
  }
});</script><body display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 Body-sc-1a1um6n-0 buHjOu"><noscript>&lt;iframe src=&quot;//www.googletagmanager.com/ns.html?id=GTM-TDQHZW&quot; height=&quot;0&quot; width=&quot;0&quot; style=&quot;display:none;visibility:hidden&quot;&gt;&lt;/iframe&gt;</noscript><div display="flex" id="reveal-ad-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 dtUqX"></div><div display="flex" id="display-top-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 bkGKbH"></div><div class="Box-sc-5gsflb-0 fvIqJh"><header data-component="HeaderBox" height="6,12,12" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 eRnwHU"><div height="100%" width="100%" class="Box-sc-5gsflb-0 cUeyxN"></div><div height="100%" width="100%" class="Box-sc-5gsflb-0 iotMlz"></div><div class="Box-sc-5gsflb-0 jhwRwY"><div display="inline-flex" height="4" data-component="MenuLink" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 MenuLink___StyledFlex-xkgwj4-0 gvphXn"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#FFFFFF" d="M3.11111111,19 L20.8888889,19 C21.5,19 22,18.55 22,18 C22,17.45 21.5,17 20.8888889,17 L3.11111111,17 C2.5,17 2,17.45 2,18 C2,18.55 2.5,19 3.11111111,19 Z M3.04709326,13 L15.0028895,13 C15.5787908,13 16.0499828,12.55 16.0499828,12 C16.0499828,11.45 15.5787908,11 15.0028895,11 L3.04709326,11 C2.47119197,11 2,11.45 2,12 C2,12.55 2.47119197,13 3.04709326,13 Z M2,6 C2,6.55 2.5,7 3.11111111,7 L20.8888889,7 C21.5,7 22,6.55 22,6 C22,5.45 21.5,5 20.8888889,5 L3.11111111,5 C2.5,5 2,5.45 2,6 Z"></path></g></svg><div color="white" display="none" font-family="openSans" font-size="4" class="Box-sc-5gsflb-0 Text-qbt5xm-0 gLVmtd">Menu</div></div></div><div display="block,inline-flex,inline-flex" width="100%" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 jwpHfP"><div class="Box-sc-5gsflb-0 bYvcEA"><a href="https://lacrossetribune.com" data-component="HeaderLogo" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 errSUj"><div class="Box-sc-5gsflb-0 irxurr"><img src="https://www.legacy.com/media/lacrossetribune.png" class="Box-sc-5gsflb-0 Image-sc-15i6sb4-0 egqvFf"/></div></a></div><div display="none,block,block" width="calc(30% + 80px)" class="Box-sc-5gsflb-0 cMbTyt"><div display="inline-flex" height="5" width="100%" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 coQyjQ"><div data-component="SearchLink" display="inline-flex" width="100%" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 lfCYmj"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M16.9376759,15.1789833 L16.0114311,15.1789833 L15.4019714,14.5812482 C16.8089255,12.9398017 17.5358518,10.7003998 17.1372148,8.32030238 C16.5861578,5.06085868 13.8660465,2.45799357 10.5831536,2.05935657 C5.62364033,1.44967646 1.44967646,5.62364033 2.05935657,10.5831536 C2.45799357,13.8660465 5.06085868,16.5861578 8.32030238,17.1372148 C10.7003998,17.5358518 12.9398017,16.8089255 14.5812482,15.4019714 L15.1789833,16.0114311 L15.1789833,16.9376759 L19.8807754,21.639468 C20.3614847,22.1201773 21.1470341,22.1201773 21.6277434,21.639468 C22.1084527,21.1587587 22.1084527,20.3732093 21.6277434,19.8925 L16.9376759,15.1789833 Z M9.62173494,14.8978129 C6.70230515,14.8978129 4.34565701,12.5411647 4.34565701,9.62173494 C4.34565701,6.70230515 6.70230515,4.34565701 9.62173494,4.34565701 C12.5411647,4.34565701 14.8978129,6.70230515 14.8978129,9.62173494 C14.8978129,12.5411647 12.5411647,14.8978129 9.62173494,14.8978129 Z"></path></g></svg><div color="neutral75" font-family="openSans" font-size="4" class="Box-sc-5gsflb-0 Text-qbt5xm-0 bvLsif">Search by Name</div></div></div></div></div><div display="none" class="Box-sc-5gsflb-0 htmZyb"><div width="320px" data-component="HeaderMenuBox" class="Box-sc-5gsflb-0 gyUeB"><div display="inline-flex" height="9" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 gpbHXj"><span role="button" tabindex="0" data-component="HeaderMenuCloseButton" class="Menu___StyledSpan-sc-1rdpebg-0 jaPksK"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M21.556314,2.45885476 C20.9647327,1.86727342 20.0091013,1.86727342 19.4175199,2.45885476 L12,9.86120592 L4.58248009,2.44368601 C3.99089875,1.85210466 3.03526735,1.85210466 2.44368601,2.44368601 C1.85210466,3.03526735 1.85210466,3.99089875 2.44368601,4.58248009 L9.86120592,12 L2.44368601,19.4175199 C1.85210466,20.0091013 1.85210466,20.9647327 2.44368601,21.556314 C3.03526735,22.1478953 3.99089875,22.1478953 4.58248009,21.556314 L12,14.1387941 L19.4175199,21.556314 C20.0091013,22.1478953 20.9647327,22.1478953 21.556314,21.556314 C22.1478953,20.9647327 22.1478953,20.0091013 21.556314,19.4175199 L14.1387941,12 L21.556314,4.58248009 C22.1327266,4.0060675 22.1327266,3.03526735 21.556314,2.45885476 Z"></path></g></svg></span><div color="neutral75" font-family="openSans" font-size="4" class="Box-sc-5gsflb-0 Text-qbt5xm-0 isXQlE">Menu</div></div><div class="Box-sc-5gsflb-0 irxurr"><div class="Box-sc-5gsflb-0 dfwUzs"><div color="gold" font-family="openSans" font-size="5" font-weight="bold" letter-spacing="6" class="Box-sc-5gsflb-0 Text-qbt5xm-0 hZjFfA">La Crosse Tribune</div><a color="neutral75" data-component="HeaderMenuLaCrosseTribuneHomepageLink" display="flex" font-family="openSans" font-size="5" href="https://lacrossetribune.com" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 MenuItem___StyledLink-sc-1li6mmx-0 eqkxAy">La Crosse Tribune Homepage<div height="3" class="Box-sc-5gsflb-0 iEGUtx"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#CCD0D2" d="M7.17371795,18.4737193 L13.6333333,12 L13.6333333,12 L7.17371795,5.52628065 C6.52528448,4.87643139 6.52585825,3.82414175 7.175,3.175 C7.82393458,2.52606542 8.87606542,2.52606542 9.525,3.175 L18.35,12 L18.35,12 L9.525,20.825 C8.87606542,21.4739346 7.82393458,21.4739346 7.175,20.825 C6.52585825,20.1758583 6.52528448,19.1235686 7.17371795,18.4737193 Z"></path></g></svg></div></a><a color="neutral75" data-component="HeaderMenuObituariesSectionLink" display="flex" font-family="openSans" font-size="5" href="https://www.legacy.com/us/obituaries/lacrossetribune/browse" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 MenuItem___StyledLink-sc-1li6mmx-0 eqkxAy">Obituaries Section<div height="3" class="Box-sc-5gsflb-0 iEGUtx"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#CCD0D2" d="M7.17371795,18.4737193 L13.6333333,12 L13.6333333,12 L7.17371795,5.52628065 C6.52528448,4.87643139 6.52585825,3.82414175 7.175,3.175 C7.82393458,2.52606542 8.87606542,2.52606542 9.525,3.175 L18.35,12 L18.35,12 L9.525,20.825 C8.87606542,21.4739346 7.82393458,21.4739346 7.175,20.825 C6.52585825,20.1758583 6.52528448,19.1235686 7.17371795,18.4737193 Z"></path></g></svg></div></a><a color="neutral75" data-component="HeaderMenuSubmitanObituaryLink" display="flex" font-family="openSans" font-size="5" href="https://lacrossetribune.com/place_an_ad/obituaries/" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 MenuItem___StyledLink-sc-1li6mmx-0 eqkxAy">Submit an Obituary<div height="3" class="Box-sc-5gsflb-0 iEGUtx"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#CCD0D2" d="M7.17371795,18.4737193 L13.6333333,12 L13.6333333,12 L7.17371795,5.52628065 C6.52528448,4.87643139 6.52585825,3.82414175 7.175,3.175 C7.82393458,2.52606542 8.87606542,2.52606542 9.525,3.175 L18.35,12 L18.35,12 L9.525,20.825 C8.87606542,21.4739346 7.82393458,21.4739346 7.175,20.825 C6.52585825,20.1758583 6.52528448,19.1235686 7.17371795,18.4737193 Z"></path></g></svg></div></a></div><div height="1px" width="100%" class="Box-sc-5gsflb-0 cLWLEN"></div></div><div class="Box-sc-5gsflb-0 irxurr"><div class="Box-sc-5gsflb-0 kARQQk"><a color="neutral75" data-component="HeaderMenuSearchLink" display="flex" font-family="ptSerif" font-size="8" font-weight="bold" href="https://www.legacy.com/obituaries/lacrossetribune/obituary-search.aspx" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 MenuItem___StyledLink-sc-1li6mmx-0 iOAseJ"><div height="3" class="Box-sc-5gsflb-0 bgfA-DJ"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#B49561" d="M16.9376759,15.1789833 L16.0114311,15.1789833 L15.4019714,14.5812482 C16.8089255,12.9398017 17.5358518,10.7003998 17.1372148,8.32030238 C16.5861578,5.06085868 13.8660465,2.45799357 10.5831536,2.05935657 C5.62364033,1.44967646 1.44967646,5.62364033 2.05935657,10.5831536 C2.45799357,13.8660465 5.06085868,16.5861578 8.32030238,17.1372148 C10.7003998,17.5358518 12.9398017,16.8089255 14.5812482,15.4019714 L15.1789833,16.0114311 L15.1789833,16.9376759 L19.8807754,21.639468 C20.3614847,22.1201773 21.1470341,22.1201773 21.6277434,21.639468 C22.1084527,21.1587587 22.1084527,20.3732093 21.6277434,19.8925 L16.9376759,15.1789833 Z M9.62173494,14.8978129 C6.70230515,14.8978129 4.34565701,12.5411647 4.34565701,9.62173494 C4.34565701,6.70230515 6.70230515,4.34565701 9.62173494,4.34565701 C12.5411647,4.34565701 14.8978129,6.70230515 14.8978129,9.62173494 C14.8978129,12.5411647 12.5411647,14.8978129 9.62173494,14.8978129 Z"></path></g></svg></div>Find an Obituary</a><a color="neutral75" data-component="HeaderMenuFlowerLink" display="flex" font-family="ptSerif" font-size="8" font-weight="bold" href="https://sympathy.legacy.com" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 MenuItem___StyledLink-sc-1li6mmx-0 iOAseJ"><div height="3" class="Box-sc-5gsflb-0 bgfA-DJ"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#B49561" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg></div>Sympathy Ideas</a><a color="neutral75" data-component="HeaderMenuRibbonLink" display="flex" font-family="ptSerif" font-size="8" font-weight="bold" href="https://www.legacy.com/tag/grieving/" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 MenuItem___StyledLink-sc-1li6mmx-0 iOAseJ"><div height="3" class="Box-sc-5gsflb-0 bgfA-DJ"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#B49561" d="M9.23915217,15.7892422 C9.59908018,16.3171366 9.9830034,16.8570286 10.3989202,17.4209158 C10.6988602,17.8208358 11.0027994,18.2127574 11.2987403,18.5886823 C9.9470106,20.2563487 8.76724655,21.5280944 8.32333533,22 L8.32333533,22 L5,20.4443111 C5.72785443,19.6844631 7.4035193,17.9128174 9.23915217,15.7892422 Z M7.32753449,4.97140572 C7.63147371,6.79904019 9.29114177,9.5744851 12.3345331,13.3617277 C14.85003,16.4931014 17.6054789,19.4085183 18.5972805,20.4363127 L18.5972805,20.4363127 L15.2739452,21.9920016 C13.9942012,20.6402719 6.61967606,12.629874 6.61967606,7.66286743 C6.61967606,6.76704659 6.87162567,5.82323535 7.32753449,4.97140572 Z M16.2697461,4.97540492 C16.7256549,5.82723455 16.9776045,6.76704659 16.9776045,7.66686663 C16.9776045,9.66246751 15.7858428,12.14997 14.2781444,14.5014997 C13.830234,13.9696061 13.3783243,13.4217157 12.9344131,12.869826 C12.7104579,12.5938812 12.4945011,12.3219356 12.2865427,12.0579884 C14.6780644,8.93061388 16.0017996,6.58308338 16.2697461,4.97540492 Z M11.7986403,2 C13.0903819,2 14.3421316,2.57988402 15.3179364,3.63167367 C15.6738652,4.05158968 15.6258748,4.84743051 15.1819636,5.96320736 C14.1861628,5.16736653 13.0103979,4.73545291 11.7986403,4.73545291 C10.5868826,4.73545291 9.41111778,5.16736653 8.41531694,5.96320736 C7.97140572,4.84743051 7.92341532,4.05158968 8.27934413,3.63167367 C9.25514897,2.57988402 10.5068986,2 11.7986403,2 Z"></path></g></svg></div>Grief Support</a></div></div></div></div></header><div display="none" height="1px" opacity="15%" class="Box-sc-5gsflb-0 ctxrXY"></div></div><div data-component="HeaderSearchNavigationMobile" display="block,none,none" width="100%" class="Box-sc-5gsflb-0 fCxlhM"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 gVODic"><div height="100%" width="100%" class="Box-sc-5gsflb-0 ffnbTU"></div><div height="100%" width="100%" class="Box-sc-5gsflb-0 hvKWli"></div><div display="inline-flex" height="5" width="100%" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 coQyjQ"><div data-component="SearchLink" display="inline-flex" width="100%" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 dVVdwO"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M16.9376759,15.1789833 L16.0114311,15.1789833 L15.4019714,14.5812482 C16.8089255,12.9398017 17.5358518,10.7003998 17.1372148,8.32030238 C16.5861578,5.06085868 13.8660465,2.45799357 10.5831536,2.05935657 C5.62364033,1.44967646 1.44967646,5.62364033 2.05935657,10.5831536 C2.45799357,13.8660465 5.06085868,16.5861578 8.32030238,17.1372148 C10.7003998,17.5358518 12.9398017,16.8089255 14.5812482,15.4019714 L15.1789833,16.0114311 L15.1789833,16.9376759 L19.8807754,21.639468 C20.3614847,22.1201773 21.1470341,22.1201773 21.6277434,21.639468 C22.1084527,21.1587587 22.1084527,20.3732093 21.6277434,19.8925 L16.9376759,15.1789833 Z M9.62173494,14.8978129 C6.70230515,14.8978129 4.34565701,12.5411647 4.34565701,9.62173494 C4.34565701,6.70230515 6.70230515,4.34565701 9.62173494,4.34565701 C12.5411647,4.34565701 14.8978129,6.70230515 14.8978129,9.62173494 C14.8978129,12.5411647 12.5411647,14.8978129 9.62173494,14.8978129 Z"></path></g></svg><div color="neutral75" font-family="openSans" font-size="4" class="Box-sc-5gsflb-0 Text-qbt5xm-0 bvLsif">Search by Name</div></div></div></div></div><div class="Box-sc-5gsflb-0 eflLnj"><div height="0" width="100%" class="Box-sc-5gsflb-0 StickyBar___StyledBox-cnyit7-0 eRbUdF"><div width="100%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 bdgHte"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 gdXIvQ"><div display="none,none,block" class="Box-sc-5gsflb-0 beBEFX"><button color="neutral75" data-component="SympathyActionSignGuestbookButton" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Secondary__SecondaryButton-u9o7zk-0 fYHBxB Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M4.89747411,14.2875916 L3,21 L9.74990789,19.1025259 L17.2498055,11.6026282 L12.4198715,6.75019446 L4.89747411,14.2875916 Z M20.002268,3.99773202 L20.002268,3.997732 C18.6700236,2.66742265 16.5120781,2.66742265 15.1798338,3.99773205 L13.4998567,5.69270892 L18.3072911,10.5001433 L20.002268,8.80516644 L20.002268,8.80516638 C21.3325774,7.47292206 21.3325774,5.31497651 20.0022679,3.98273219 L20.002268,3.99773202 Z"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Sign the Guest Book</span></button></div><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=205" display="block" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 brikZx"><button color="white" data-component="SympathyActionSendFlowersButton" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Primary__PrimaryButton-sc-1s1zddg-0 kAaEdl Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#FFFFFF" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a></div><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 gdXIvQ"><div class="Box-sc-5gsflb-0 fVWyrk"><button color="neutral75" data-component="SympathyActionShareButton" display="none,flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 jhyKJF Box-sc-5gsflb-0 kpFUuW" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M13.9909111,5.41339801 L13.9909112,5.41339808 C13.2934238,4.86220068 12.2884018,4.86220068 11.5909108,5.41339792 L11.5909108,5.4133979 C11.2788935,5.65430962 11.0954252,6.01706826 11.0909107,6.40201746 L11.0909107,8.50174042 C5.80909158,8.93918271 2,12.7974236 2,18.7816341 C2,18.7816341 5.11818237,15.8157754 11.0909107,15.5270635 L11.0909107,17.6005399 L11.0909106,17.6005354 C11.0954243,17.9854846 11.2788907,18.3482442 11.5909071,18.589155 L11.5909073,18.5891551 C12.2896574,19.1369483 13.2921621,19.1369483 13.9909077,18.5891549 L22,12.0012741 L13.9909111,5.41339801 Z"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Share</span></button><button color="neutral75" data-component="SympathyActionShareButton" display="flex,none" width="40px" height="40px" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 cKDCdi Box-sc-5gsflb-0 iMPzou" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M13.9909111,5.41339801 L13.9909112,5.41339808 C13.2934238,4.86220068 12.2884018,4.86220068 11.5909108,5.41339792 L11.5909108,5.4133979 C11.2788935,5.65430962 11.0954252,6.01706826 11.0909107,6.40201746 L11.0909107,8.50174042 C5.80909158,8.93918271 2,12.7974236 2,18.7816341 C2,18.7816341 5.11818237,15.8157754 11.0909107,15.5270635 L11.0909107,17.6005399 L11.0909106,17.6005354 C11.0954243,17.9854846 11.2788907,18.3482442 11.5909071,18.589155 L11.5909073,18.5891551 C12.2896574,19.1369483 13.2921621,19.1369483 13.9909077,18.5891549 L22,12.0012741 L13.9909111,5.41339801 Z"></path></g></svg></button></div></div></div></div><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 cuaVkT"><div width="100%" class="Box-sc-5gsflb-0 gZhEYU"><div height="100%" class="Box-sc-5gsflb-0 hGNevv"><div data-component="NameSection" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 NameSection__NameSectionStyled-sc-7qx63u-0 ccRACY"><div class="Box-sc-5gsflb-0 bqlnrG"><div color="white" data-component="NameHeadingText" font-family="ptSerif" font-size="12,12,15,17,19" font-weight="bold" class="Box-sc-5gsflb-0 Text-qbt5xm-0 dKTqL">Stanley A. Engen</div><div color="gold50" data-component="LifespanText" font-size="8,8,10" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 dHxpEd">1922 - 2021</div></div></div></div></div><div width="100%" class="Box-sc-5gsflb-0 gZhEYU"><div class="Box-sc-5gsflb-0 frKZQv"><div width="100%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 hGsKEx"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 blGwuT"><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=205" display="block" width="100%" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 dyFuXm"><button color="white" data-component="SympathyActionSendFlowersButton" display="flex" width="100%" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Primary__PrimaryButton-sc-1s1zddg-0 cfQUzi Box-sc-5gsflb-0 cemlWY" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#FFFFFF" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a></div><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 jUkITv"><button color="neutral75" data-component="SympathyActionShareButton" display="flex" width="100%" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Secondary__SecondaryButton-u9o7zk-0 bOsxPO Box-sc-5gsflb-0 cemlWY" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M13.9909111,5.41339801 L13.9909112,5.41339808 C13.2934238,4.86220068 12.2884018,4.86220068 11.5909108,5.41339792 L11.5909108,5.4133979 C11.2788935,5.65430962 11.0954252,6.01706826 11.0909107,6.40201746 L11.0909107,8.50174042 C5.80909158,8.93918271 2,12.7974236 2,18.7816341 C2,18.7816341 5.11818237,15.8157754 11.0909107,15.5270635 L11.0909107,17.6005399 L11.0909106,17.6005354 C11.0954243,17.9854846 11.2788907,18.3482442 11.5909071,18.589155 L11.5909073,18.5891551 C12.2896574,19.1369483 13.2921621,19.1369483 13.9909077,18.5891549 L22,12.0012741 L13.9909111,5.41339801 Z"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Share</span></button></div></div></div><div class="Box-sc-5gsflb-0 iobueB"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 bOSjrw"><div data-component="AttributeGroup" width="100%,50%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 kSeRsR"><div color="neutral75" data-component="AttributeHeaderText" font-size="4" font-weight="bold" width="40%,100%" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jyfyWv">BORN</div><div data-component="AttributeValuesBox" width="60%,100%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 eCZOyq"><div color="neutral75" data-component="AttributeValueText" font-family="openSans" font-size="4" width="60%,100%" class="Box-sc-5gsflb-0 Text-qbt5xm-0 EEYiT">1922</div></div></div><div data-component="AttributeGroup" width="100%,50%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 kSeRsR"><div color="neutral75" data-component="AttributeHeaderText" font-size="4" font-weight="bold" width="40%,100%" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jyfyWv">DIED</div><div data-component="AttributeValuesBox" width="60%,100%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 eCZOyq"><div color="neutral75" data-component="AttributeValueText" font-family="openSans" font-size="4" width="60%,100%" class="Box-sc-5gsflb-0 Text-qbt5xm-0 EEYiT">2021</div></div></div></div><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 fTHKVG"><div data-component="AttributeGroup" width="100%,50%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 kSeRsR"><div color="neutral75" data-component="AttributeHeaderText" font-size="4" font-weight="bold" width="40%,100%" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jyfyWv">FUNERAL HOME</div><div data-component="AttributeValuesBox" width="60%,100%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 eCZOyq"><div color="neutral75" data-component="AttributeValueText" font-family="openSans" font-size="4" width="60%,100%" class="Box-sc-5gsflb-0 Text-qbt5xm-0 EEYiT">McCormick Funeral Home</div><div color="neutral75" data-component="AttributeValueText" font-family="openSans" font-size="4" width="60%,100%" class="Box-sc-5gsflb-0 Text-qbt5xm-0 EEYiT">205 E Main St</div><div color="neutral75" data-component="AttributeValueText" font-family="openSans" font-size="4" width="60%,100%" class="Box-sc-5gsflb-0 Text-qbt5xm-0 EEYiT">Caledonia, MN</div></div></div><div display="flex" id="custom-attribute-1" width="100%,50%" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 gqHQuw"></div></div></div><div class="Box-sc-5gsflb-0 einChR"><div color="neutral75" data-component="ObituaryParagraph" font-family="ptSerif" font-size="5,5,5,5,8" class="Box-sc-5gsflb-0 Text-qbt5xm-0 ObituaryText___StyledText-sc-1vgmcq9-0 fRUyiB"><p>Stanley A. Engen</p> <p>CALEDONIA - Stanley A. Engen, age 99, of Caledonia, passed away December 11, 2021 at Northgate Care Center, Waukon, Iowa. Services will be at 11:00 a.m., Thursday, December 23, 2021, at Immanuel Lutheran Church, Caledonia. Visitation will be from 4:00 p.m. to 7:00 p.m., Wednesday, December 22, 2021, at the church, and also one hour prior to the service on Thursday. A full obituary will be in next week&#x27;s paper. McCormick Funeral Home, Caledonia is assisting the family. Onlinecondolences may be given <a color="blue" href="http://mccormickfuneralhome.net" text-decoration="underline" class="Box-sc-5gsflb-0 Link-we4j6d-0 jjheVM">mccormickfuneralhome.net</a></p><br/></div><div color="neutral75" data-component="ObituaryEndorsementText" font-size="4" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 iVTHRL">Published by La Crosse Tribune on Dec. 19, 2021.</div><div class="Box-sc-5gsflb-0 gaFajL"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 ccZCRO"><div height="1px" class="Box-sc-5gsflb-0 eKqkFR"></div><svg width="68px" height="24px" viewBox="0 0 68 24"><title>34465541-95D0-45B0-BEEB-B9E0361A315A</title><g id="Tree-CTA-Exploration" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="XL-Tree-CTA-Publish-Line-Above-Obit-with-flourish" transform="translate(-942.000000, -1731.000000)" fill="#404F57"><g id="Obit-Section" transform="translate(0.000000, 218.000000)"><g id="Obituary" transform="translate(656.000000, 462.000000)"><g id="End-Cap" transform="translate(96.000000, 1051.000000)"><path d="M246.18656,6.62370024 C242.519081,6.94069163 239.156574,8.40522291 236.015583,10.1502294 C232.869132,11.919321 229.842799,13.9277101 226.821925,15.9788308 C223.740212,17.9351649 220.65928,19.9622005 217.296773,21.5207415 C213.966246,23.0637437 210.287847,24.2283762 206.594628,23.9618859 C210.258208,23.6379021 213.644113,22.2572803 216.816304,20.5581132 C219.986934,18.8410766 223.028868,16.8575496 226.049742,14.8103136 C229.131454,12.8617489 232.182747,10.8059665 235.519514,9.19925525 C238.821182,7.61041363 242.488661,6.35410218 246.18656,6.62370024 Z M209.967274,2.77862581 C211.469521,3.01093078 212.972548,3.35744587 214.406157,3.96345881 C215.112041,4.29288123 215.814026,4.64794266 216.415393,5.17626164 C217.00116,5.67117221 217.562748,6.42946533 217.44263,7.20795888 C216.98634,5.73021962 215.338236,5.42099763 214.040345,5.03485862 C212.647295,4.71009784 211.214467,4.52829395 209.771498,4.41019912 C206.885561,4.20819481 203.929426,4.00152886 201.124608,4.46613878 C198.322909,4.94939525 195.511851,5.87006876 193.297479,7.61196751 C192.225003,8.48602464 191.299163,9.60326388 190.97313,10.9139611 C190.677516,12.203681 190.898252,13.723375 191.453599,15.0029946 C192.576775,17.6935367 195.392513,19.3080173 198.212151,19.9862856 C201.063769,20.664554 204.125202,20.7997415 206.976039,20.059318 C212.722954,18.5093233 217.387251,14.7411659 222.357302,11.5751368 C227.307074,8.38579942 232.588338,5.20967004 238.44991,3.81195558 C241.370946,3.08474004 244.3926,3.19040384 247.347955,3.53303423 C250.279911,3.93160429 253.271145,4.80410754 255.610314,6.82104292 C256.747529,7.83728001 257.61955,9.23654836 257.895664,10.8036357 C258.195957,12.3629536 257.830145,14.0473588 257.028323,15.4132187 C255.404399,18.1931089 252.534061,19.9210227 249.573246,20.7950798 C246.567192,21.7134225 243.380182,21.6675831 240.388947,21.0452544 C238.8867,20.7298169 237.412533,20.22636 236.055362,19.479721 C235.379117,19.1075669 234.737191,18.6616035 234.181843,18.1099763 C233.656135,17.5785496 233.069588,16.8925119 233.153826,16.1008103 C233.649895,17.5233869 235.218441,18.0307285 236.481233,18.564486 C237.829044,19.0485195 239.236913,19.3530798 240.654922,19.5574149 C243.501079,19.904707 246.411196,20.0344559 249.142696,19.2901477 C251.837537,18.5419548 254.44814,17.0743158 256.036185,14.8056519 C257.695208,12.5602963 257.314577,9.23654836 255.225003,7.21572827 C253.195487,5.11721422 250.199573,4.19110214 247.318316,3.72183057 C244.407419,3.28519048 241.346767,3.16554177 238.535708,4.1258392 C234.405009,5.48279422 230.8587,7.93094721 227.309011,10.4009146 L226.187258,11.1803821 C225.251228,11.8284639 224.31068,12.4702609 223.354901,13.0862844 C218.419169,16.3206843 213.002967,19.3577414 207.061058,20.4477878 C204.099462,20.9574602 201.073909,20.8650044 198.141953,20.2690917 C195.247436,19.6498708 192.34122,18.0548136 190.888112,15.2733696 C190.196267,13.8857553 189.830455,12.3505226 190.07693,10.7236109 C190.367083,9.10913025 191.374041,7.7588091 192.511256,6.70450197 C194.846525,4.59044913 197.83152,3.41960104 200.847714,2.87574327 C203.909147,2.33266244 206.96044,2.37617106 209.967274,2.77862581 Z M239.161254,0.0368057165 C235.500015,0.353797102 232.137508,1.81832838 228.996517,3.56255794 C225.849286,5.33087263 222.817492,7.34003862 219.797399,9.39193629 C216.721146,11.3474934 213.633974,13.3737521 210.277707,14.93307 C206.94562,16.4752953 203.263321,17.6407048 199.570882,17.3734375 C203.232901,17.0494537 206.625047,15.6696088 209.791778,13.9696648 C212.967868,12.2534051 216.004342,10.2698781 219.025995,8.22341903 C222.106148,6.27485433 225.163681,4.21829502 228.494208,2.61158379 C231.802116,1.02196522 235.464135,-0.233569289 239.161254,0.0368057165 Z" id="Flourish"></path></g></g></g></g></g></svg><div height="1px" class="Box-sc-5gsflb-0 cGbLzi"></div></div><div color="neutral75" font-family="openSans" font-size="5" font-weight="bold" class="Box-sc-5gsflb-0 Text-qbt5xm-0 bUmJvr">To plant trees in memory, please visit the<!-- --> <a data-component="TreesInlineCTA" href="https://sympathy.legacy.com/en-us/funeral-flowers/productdetails/?type=obituary&amp;p=200853248&amp;pn=stanley-engen&amp;affiliateId=4372&amp;v=01&amp;sku=tre-tim&amp;pm=322" color="blue" text-decoration="underline" class="Box-sc-5gsflb-0 Link-we4j6d-0 jjheVM">Sympathy Store</a>.</div></div><div class="Box-sc-5gsflb-0 kFMEng"><div display="flex" id="custom-integratedtextlink-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 fHPHBL"></div></div></div><div height="1px" class="Box-sc-5gsflb-0 cJHOpW"></div></div></div><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 jyNlRP"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 bywtdM"><div order="2,2,1" width="100%" class="Box-sc-5gsflb-0 igsVRa"><div class="Box-sc-5gsflb-0 bQzMjo"><div color="gold" font-size="5,6" font-weight="bold" letter-spacing="6,7" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 dcYJDY">MEMORIAL EVENTS</div><div width="100%" overflow="auto,auto,visible" data-component="MemorialEventsBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 MemorialEvents___StyledFlex-sc-1dwxdfm-0 cYTACw"><div class="Box-sc-5gsflb-0 irxurr"><div height="272px,100%,100%,100%" width="280px,100%,100%,100%" data-component="MemorialEventBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 dlOLXj"><div data-component="MemorialEventDateBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 kuiryZ"><div color="red" font-size="5,5,5,8" font-weight="bold" width="6,6,6,8" data-component="MemorialEventMonthText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 RFTIi">Dec</div><div color="neutral75" font-size="9,9,9,12" font-weight="bold" width="6,6,6,8" data-component="MemorialEventDayText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jasQKc">22</div></div><div width="calc(100% - 64px)" class="Box-sc-5gsflb-0 hZxNlF"><div color="neutral75" font-size="5,5,5,8" font-weight="bold" data-component="MemorialEventNameText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText-sc-19kqo7k-1 ecUOxL">Visitation</div><div color="neutral75" font-size="4" overflow="hidden" data-component="MemorialEventTimeText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText2-sc-19kqo7k-2 hvJPuz">4:00p.m. - 7:00p.m.</div><div color="neutral75" font-size="4" overflow="hidden" data-component="MemorialEventLocationNameText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText3-sc-19kqo7k-3 dFeBZn">Immanuel Lutheran Church</div><div color="neutral75" font-size="4" data-component="MemorialEventLocationAddressText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails__Address-sc-19kqo7k-0 IoPjg">Caledonia, MN</div><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=206" display="block,block,none" data-component="MemorialEventSendFlowersButton" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 gsSWaH"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 OXWIL Box-sc-5gsflb-0 fUNOGC" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=206" display="none,none,block" data-component="MemorialEventSendFlowersButton" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 cSuuvE"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 czcTYW Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a></div></div></div><div class="Box-sc-5gsflb-0 irxurr"><div height="272px,100%,100%,100%" width="280px,100%,100%,100%" data-component="MemorialEventBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 dlOLXj"><div data-component="MemorialEventDateBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 kuiryZ"><div color="red" font-size="5,5,5,8" font-weight="bold" width="6,6,6,8" data-component="MemorialEventMonthText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 RFTIi">Dec</div><div color="neutral75" font-size="9,9,9,12" font-weight="bold" width="6,6,6,8" data-component="MemorialEventDayText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jasQKc">23</div></div><div width="calc(100% - 64px)" class="Box-sc-5gsflb-0 hZxNlF"><div color="neutral75" font-size="5,5,5,8" font-weight="bold" data-component="MemorialEventNameText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText-sc-19kqo7k-1 ecUOxL">Visitation</div><div color="neutral75" font-size="4" overflow="hidden" data-component="MemorialEventTimeText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText2-sc-19kqo7k-2 hvJPuz">10:00a.m. - 11:00a.m.</div><div color="neutral75" font-size="4" overflow="hidden" data-component="MemorialEventLocationNameText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText3-sc-19kqo7k-3 dFeBZn">Immanuel Lutheran Church</div><div color="neutral75" font-size="4" data-component="MemorialEventLocationAddressText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails__Address-sc-19kqo7k-0 IoPjg">Caledonia, MN</div><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=206" display="block,block,none" data-component="MemorialEventSendFlowersButton" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 gsSWaH"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 OXWIL Box-sc-5gsflb-0 fUNOGC" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=206" display="none,none,block" data-component="MemorialEventSendFlowersButton" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 cSuuvE"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 czcTYW Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a></div></div></div><div class="Box-sc-5gsflb-0 irxurr"><div height="272px,100%,100%,100%" width="280px,100%,100%,100%" data-component="MemorialEventBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 DavtM"><div data-component="MemorialEventDateBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 kuiryZ"><div color="red" font-size="5,5,5,8" font-weight="bold" width="6,6,6,8" data-component="MemorialEventMonthText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 RFTIi">Dec</div><div color="neutral75" font-size="9,9,9,12" font-weight="bold" width="6,6,6,8" data-component="MemorialEventDayText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jasQKc">23</div></div><div width="calc(100% - 64px)" class="Box-sc-5gsflb-0 hZxNlF"><div color="neutral75" font-size="5,5,5,8" font-weight="bold" data-component="MemorialEventNameText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText-sc-19kqo7k-1 ecUOxL">Service</div><div color="neutral75" font-size="4" overflow="hidden" data-component="MemorialEventTimeText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText2-sc-19kqo7k-2 hvJPuz">11:00a.m.</div><div color="neutral75" font-size="4" overflow="hidden" data-component="MemorialEventLocationNameText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails___StyledText3-sc-19kqo7k-3 dFeBZn">Immanuel Lutheran Church</div><div color="neutral75" font-size="4" data-component="MemorialEventLocationAddressText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 MemorialEventDetails__Address-sc-19kqo7k-0 IoPjg">Caledonia, MN</div><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=206" display="block,block,none" data-component="MemorialEventSendFlowersButton" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 gsSWaH"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 OXWIL Box-sc-5gsflb-0 fUNOGC" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a><a href="https://sympathy.legacy.com/en-us/funeral-flowers/name/stanley-engen-funeral-flowers/p200853248/?affiliateId=4372&amp;pm=206" display="none,none,block" data-component="MemorialEventSendFlowersButton" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 cSuuvE"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 czcTYW Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M9.28217822,11.1392327 L12.3267327,11.1392327 C12.3558168,11.3415842 12.3762376,11.5470297 12.3762376,11.7580446 C12.3762376,14.1503713 10.4368812,16.0897277 8.04455446,16.0897277 C7.35086634,16.0897277 6.69678218,15.9232673 6.11571782,15.6336634 C5.96472772,16.990099 5.54826733,18.2660891 4.90655941,19.4016089 C4.89789604,19.4232673 4.88675743,19.4424505 4.87623762,19.4634901 C4.87252475,19.4696782 4.8700495,19.4764851 4.86633663,19.4826733 L4.86386139,19.4814356 C4.75804455,19.6701733 4.56373762,19.8032178 4.33168317,19.8032178 C3.99009901,19.8032178 3.71287129,19.5266089 3.71287129,19.1844059 C3.71287129,19.0686881 3.75309406,18.9659653 3.80878713,18.8737624 L3.78960396,18.8626238 C4.52413366,17.5897277 4.95049505,16.1175743 4.95049505,14.542698 L4.95049505,10.4579208 C2.8539604,10.1553218 1.23762376,8.36881188 1.23762376,6.18811881 L1.23762376,4.62190594 C1.23762376,3.71039604 0.840346535,2.89418317 0.213490099,2.3279703 L0.219678218,2.32054455 C0.0878712871,2.20668317 0,2.04455446 0,1.85643564 C0,1.53094059 0.253712871,1.27165842 0.573019802,1.24690594 C0.661509901,1.25247525 0.750618812,1.25309406 0.838490099,1.2605198 C0.886138614,1.26423267 0.933168317,1.2710396 0.980816832,1.27537129 C4.09777228,1.625 6.77165842,3.9375 7.42883663,7.17636139 L7.42883663,7.17636139 L7.42883663,7.17636139 C7.4634901,7.34405941 7.62623762,7.45173267 7.79393564,7.41831683 C7.96163366,7.38490099 8.06930693,7.22153465 8.03527228,7.05383663 L8.03527228,7.05383663 C7.66027228,5.20173267 6.73514851,3.60519802 5.46905941,2.38861386 C6.19183168,1.76608911 7.00061881,1.30321782 7.85457921,1.0049505 C7.85519802,1.00556931 7.85519802,1.00556931 7.85519802,1.00556931 C8.59529703,0.756806931 9.38613861,0.618811881 10.210396,0.618811881 C10.3805693,0.618811881 10.519802,0.757425743 10.519802,0.928217822 C10.519802,1.03094059 10.4665842,1.11757426 10.3892327,1.17326733 L10.3954208,1.18193069 C10.0965347,1.40841584 9.9009901,1.76299505 9.9009901,2.16584158 L9.9009901,6.18811881 C9.9009901,8.36819307 8.28527228,10.154703 6.18811881,10.457302 L6.18811881,12.8038366 C6.85272277,11.8013614 7.98886139,11.1392327 9.28217822,11.1392327 Z M2.78527228,0.604579208 C2.98762376,0.505569307 3.19368812,0.412747525 3.3960396,0.324876238 C3.39789604,0.323638614 3.39975248,0.324876238 3.40222772,0.323638614 C4.38737624,-0.105816832 5.54579208,-0.125618812 6.59529703,0.366955446 C6.59653465,0.368193069 6.59839109,0.368193069 6.60024752,0.369430693 C6.76113861,0.440594059 6.92264851,0.514232673 7.0835396,0.59220297 C6.34096535,0.945544554 5.63799505,1.40841584 4.99381188,1.98019802 C4.32487624,1.4220297 3.58725248,0.95049505 2.78527228,0.604579208 Z" transform="translate(6 2)"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Send Flowers</span></button></a></div></div></div></div><div class="Box-sc-5gsflb-0 jalWxn"><div color="neutral50" font-size="4" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 gShwQI">Funeral services provided by:</div><div color="neutral75" font-family="ptSerif" font-weight="bold" data-component="MemorialEventsFuneralHomeNameText" font-size="5" class="Box-sc-5gsflb-0 Text-qbt5xm-0 kceUMz">McCormick Funeral Home</div><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 dGyLhb"><a data-component="FuneralHomeCallButton" display="block,none" href="tel:(507) 725-2616" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 fweLYU"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 OXWIL Box-sc-5gsflb-0 fUNOGC" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M20.01,15.38 C18.78,15.38 17.59,15.18 16.48,14.82 C16.13,14.7 15.74,14.79 15.47,15.06 L13.9,17.03 C11.07,15.68 8.42,13.13 7.01,10.2 L8.96,8.54 C9.23,8.26 9.31,7.87 9.2,7.52 C8.83,6.41 8.64,5.22 8.64,3.99 C8.64,3.45 8.19,3 7.65,3 L4.19,3 C3.65,3 3,3.24 3,3.99 C3,13.28 10.73,21 20.01,21 C20.72,21 21,20.37 21,19.82 L21,16.37 C21,15.83 20.55,15.38 20.01,15.38 Z"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">Call</span></button></a><a data-component="FuneralHomeCallButton" display="none,block" href="tel:(507) 725-2616" text-decoration="none" class="Box-sc-5gsflb-0 Link-we4j6d-0 illkbs"><button color="neutral75" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Tertiary__TertiaryButton-sc-1kjhrhp-0 czcTYW Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M20.01,15.38 C18.78,15.38 17.59,15.18 16.48,14.82 C16.13,14.7 15.74,14.79 15.47,15.06 L13.9,17.03 C11.07,15.68 8.42,13.13 7.01,10.2 L8.96,8.54 C9.23,8.26 9.31,7.87 9.2,7.52 C8.83,6.41 8.64,5.22 8.64,3.99 C8.64,3.45 8.19,3 7.65,3 L4.19,3 C3.65,3 3,3.24 3,3.99 C3,13.28 10.73,21 20.01,21 C20.72,21 21,20.37 21,19.82 L21,16.37 C21,15.83 20.55,15.38 20.01,15.38 Z"></path></g></svg><span class="Box-sc-5gsflb-0 ikjjAK">(507) 725-2616</span></button></a></div></div><div class="Box-sc-5gsflb-0 dbutOr"><div class="Box-sc-5gsflb-0 irxurr"><div class="Box-sc-5gsflb-0 jalWxn"><div height="1px" class="Box-sc-5gsflb-0 klfWiB"></div><div class="Box-sc-5gsflb-0 irxurr"><div color="gold" data-component="SectionTitle" font-weight="bold" font-size="6" letter-spacing="7" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jmqHHP">MAKE A DONATION</div></div></div><div overflow="auto,auto,visible" width="100%" class="Box-sc-5gsflb-0 ceNmLe"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 dTODxj"><div style="width:100%"><div class="plg-search" data-partner-key="93d96b3e1088927bcd5df9cb2b3d7613" data-search-to-donate="true"></div></div></div></div><div class="Box-sc-5gsflb-0 irxurr"></div></div></div><div class="Box-sc-5gsflb-0 jalWxn"><div height="1px" class="Box-sc-5gsflb-0 klfWiB"></div><div class="Box-sc-5gsflb-0 ezSWRN"><div color="gold" font-size="5,6" font-weight="bold" letter-spacing="6,7" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 jwqrEs">MEMORIES &amp; CONDOLENCES</div><div color="neutral75" font-size="5" data-component="GuestbookSponsorshipLine" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 gSkFQr">Sponsored by <!-- -->McCormick Funeral Home<!-- -->.</div><div data-component="GuestbookBox" class="Box-sc-5gsflb-0 kmCZJm"><form><div class="Box-sc-5gsflb-0 irxurr"><div font-family="ptSerif" font-size="5" font-weight="bold" letter-spacing="x0" color="black" class="Box-sc-5gsflb-0 Text-qbt5xm-0 hHPJZp">Add a Message</div><hr height="0" class="Box-sc-5gsflb-0 Divider-sc-1bd7md2-0 eWYmTX"/><div width="100%" class="Box-sc-5gsflb-0 gRbBRX"><label for="_GuestbookForm_From" form="guest-book-add" color="neutral75" font-family="openSans" font-size="4" display="block" font-weight="bold" class="Box-sc-5gsflb-0 Text-qbt5xm-0 Label-xhtevw-0 gzWnEc">From</label><input type="text" data-component="TextBoxField" form="guest-book-add" name="_GuestbookForm_From" placeholder="Your Name" value="" width="100%" color="black" display="block" font-family="openSans" font-size="5" class="Box-sc-5gsflb-0 TextInput-sc-1u7f8z2-0 TextBox-k2tip4-0 kNhnrK"/></div><div width="100%" class="Box-sc-5gsflb-0 gRbBRX"><label for="_GuestbookForm_Message" form="guest-book-add" color="neutral75" font-family="openSans" font-size="4" display="block" font-weight="bold" class="Box-sc-5gsflb-0 Text-qbt5xm-0 Label-xhtevw-0 gzWnEc">Your Message</label><textarea data-component="TextAreaField" form="guest-book-add" name="_GuestbookForm_Message" placeholder="Offer sympathy or share a memory..." width="100%" color="black" display="block" font-family="openSans" font-size="5" class="Box-sc-5gsflb-0 TextInput-sc-1u7f8z2-0 TextArea-sc-5nv0x0-0 gZnLmh"></textarea></div><hr height="0" class="Box-sc-5gsflb-0 Divider-sc-1bd7md2-0 iAbeYT"/><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 kzlpgU"><div class="Box-sc-5gsflb-0 eINTbh"><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 svxGO"></div></div><div style="cursor:pointer" class="Box-sc-5gsflb-0 lfMLaT"><div color="blue" data-component="NotSureWhatToSayText" font-family="openSans" font-size="4" style="text-decoration:underline" class="Box-sc-5gsflb-0 Text-qbt5xm-0 gXAkdR">Not sure what to say?</div></div></div><hr height="0" class="Box-sc-5gsflb-0 Divider-sc-1bd7md2-0 iAbeYT"/></div><hr height="0" class="Box-sc-5gsflb-0 Divider-sc-1bd7md2-0 bjEiTH"/><div display="none" class="Box-sc-5gsflb-0 feLKnq"><label data-component="howDoYouKnowText" form="guest-book-add" name="_GuestbookForm_Known" color="neutral75" font-family="openSans" font-size="4" display="block" font-weight="bold" class="Box-sc-5gsflb-0 Text-qbt5xm-0 Label-xhtevw-0 gzWnEc">How do you know Stanley A. Engen? (Optional)</label><div overflow="hidden" class="Box-sc-5gsflb-0 exRfGc"><div overflow="auto" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 oSjrP"><div class="Box-sc-5gsflb-0 kuHOHt"><button color="neutral75" data-component="button-button-0" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Secondary__SecondaryButton-u9o7zk-0 fYHBxB Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><span class="Box-sc-5gsflb-0 irxurr">Family</span></button></div><div class="Box-sc-5gsflb-0 kuHOHt"><button color="neutral75" data-component="button-button-1" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Secondary__SecondaryButton-u9o7zk-0 fYHBxB Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><span class="Box-sc-5gsflb-0 irxurr">Friend</span></button></div><div class="Box-sc-5gsflb-0 kuHOHt"><button color="neutral75" data-component="button-button-2" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Secondary__SecondaryButton-u9o7zk-0 fYHBxB Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><span class="Box-sc-5gsflb-0 irxurr">Work</span></button></div><div class="Box-sc-5gsflb-0 kuHOHt"><button color="neutral75" data-component="button-button-3" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Secondary__SecondaryButton-u9o7zk-0 fYHBxB Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><span class="Box-sc-5gsflb-0 irxurr">School</span></button></div><div class="Box-sc-5gsflb-0 kuHOHt"><button color="neutral75" data-component="button-button-4" display="flex" width="auto" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Secondary__SecondaryButton-u9o7zk-0 fYHBxB Box-sc-5gsflb-0 hHseUH" font-family="openSans" font-size="4" font-weight="bold"><span class="Box-sc-5gsflb-0 irxurr">Other</span></button></div></div></div><hr height="0" class="Box-sc-5gsflb-0 Divider-sc-1bd7md2-0 bjEiTH"/><div width="100%" class="Box-sc-5gsflb-0 gRbBRX"><label for="_GuestbookForm_Email" form="guest-book-add" color="neutral75" font-family="openSans" font-size="4" display="block" font-weight="bold" class="Box-sc-5gsflb-0 Text-qbt5xm-0 Label-xhtevw-0 gzWnEc">Your Email (will not be displayed)</label><input type="text" data-component="EmailField" form="guest-book-add" name="_GuestbookForm_Email" placeholder="Email Address" value="" width="100%" color="black" display="block" font-family="openSans" font-size="5" pattern="^(([^&lt;&gt;()\[\]\\.,;:\s@&quot;]+(\.[^&lt;&gt;()\[\]\\.,;:\s@&quot;]+)*)|(&quot;.+&quot;))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$" class="Box-sc-5gsflb-0 TextInput-sc-1u7f8z2-0 TextBox-k2tip4-0 Email-sc-12kkwtu-0 kujJUz"/></div><label display="inline-block" height="3" class="Box-sc-5gsflb-0 Checkbox__CheckboxLabel-sc-17eljr4-0 bokQiP"><input type="checkbox" checked="" data-component="getEmailUpdatesCheckbox" name="_GuestbookForm_EmailUpdates" form="guest-book-add" class="Checkbox__HiddenCheckbox-sc-17eljr4-1 fLwXXC"/><svg width="24px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#B49561" d="M15.8545457,7.77272782 L10.9545457,13.4909096 L8.00000021,11.2727278 L8.00000022,11.2727278 C7.5983384,10.9714815 7.0285184,11.0528842 6.72727294,11.454546 C6.42602658,11.8562078 6.5074293,12.4260278 6.90909113,12.7272733 L11.227273,15.9636369 L17.2363639,8.95454602 L17.236364,8.954546 C17.562714,8.57296782 17.5179421,7.99908236 17.136364,7.67272782 C16.7547858,7.34637782 16.1809003,7.39114963 15.8545458,7.77272782 L15.8545457,7.77272782 Z M18.3636367,2 L5.63636382,2 L5.63636367,2 C3.62805456,2 2,3.62805509 2,5.63636419 C2,5.63636419 2,5.63636419 2,5.63636419 L2,18.3636369 L2,18.3636364 C2,20.3719455 3.62805456,22 5.63636367,22 L18.3636365,22 L18.3636363,22 C20.3719454,22 22,20.3719455 22,18.3636364 L22,5.63636364 L22,5.63636364 C22,3.62805455 20.3719454,2 18.3636363,2 L18.3636367,2 Z M19,17.25 L19,17.25 C19,18.2164987 18.2164979,19 17.25,19 L6.75000007,19 L6.74999999,19 C5.78350125,19 5,18.2164979 5,17.25 C5,17.25 5,17.25 5,17.25 L5,6.74999977 L5,6.75000003 C5,5.78350126 5.78350125,5 6.74999999,5 L17.2499999,5 L17.2499999,5 C18.2164986,5 19,5.78350126 19,6.75000003 L19,17.25 Z"></path></g></svg><div color="neutral75" display="inline-block" font-size="4" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 cqXONy">Get email updates for this page</div></label><button color="white" data-component="GuestbookSubmitButton" display="flex" width="100%" height="auto" class="Box-sc-5gsflb-0 Base__BaseButton-sc-106bjra-0 Primary__PrimaryButton-sc-1s1zddg-0 jNRqLW Box-sc-5gsflb-0 fjHPjg" font-family="openSans" font-size="4" font-weight="bold"><span class="Box-sc-5gsflb-0 irxurr">Submit Your Message</span></button></div></form></div><div class="Box-sc-5gsflb-0 hyiYzP"><div color="neutral75" font-size="4" font-weight="bold" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 kDgRpq">1<!-- --> Entry</div><div data-component="GuestbookEntryBox" class="Box-sc-5gsflb-0 eGkjxv"><div class="Box-sc-5gsflb-0 bQckYs"><div color="neutral75" font-family="ptSerif" data-component="GuestbookEntryText" font-size="5" class="Box-sc-5gsflb-0 Text-qbt5xm-0 cXrwkS">I am so sorry to hear about the passing of Stanley. May the family and friends of Stanley find comfort during this difficult time</div><div display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 wdkLT"><div class="Box-sc-5gsflb-0 irxurr"><div color="neutral75" font-size="4" font-weight="bold" data-component="GuestbookEntryAuthorText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 dVLnlD">Nate Harris</div></div><div color="neutral50" font-size="2" data-component="GuestbookEntryDateText" font-family="openSans" class="Box-sc-5gsflb-0 Text-qbt5xm-0 bbXaYN">December 18, 2021</div></div></div></div><div id="GuestbookPaginator" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 hzZggr"><div id="PaginationResultText" color="black" font-family="openSans" font-size="5" class="Box-sc-5gsflb-0 Text-qbt5xm-0 icDaJC">Showing 1 - 1 of 1 results</div></div></div></div><div height="1px" class="Box-sc-5gsflb-0 FbnVF"></div></div></div></div><div display="block" order="1,1,2" width="100%" class="Box-sc-5gsflb-0 byCaSp"><div display="block" class="Box-sc-5gsflb-0 iuipXW"><div display="flex" id="custom-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 iZBbFy"></div></div><div display="none,none,block" class="Box-sc-5gsflb-0 ecDQMb"><div display="none,none,flex" id="display-right-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 buuqHR"></div><div display="none,none,flex" id="display-right-2" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 hKngqc"></div></div></div></div></div></div><div id="345628131" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 iiDaXx"></div><div display="flex" id="display-bottom-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 bkGKbH"></div><footer data-component="FooterBox" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 hMUlVk"><ul class="FooterNavList__Container-vkkbkx-0 iDKhhp"><li class="FooterNavList__Item-vkkbkx-1 dLrXEq"><a href="https://www.legacy.com/contact/" data-component="FooterContactUsLink" class="FooterNavListElement__ListElement-sc-1ulyhz1-0 eumMbs">Contact Us</a></li><li class="FooterNavList__Item-vkkbkx-1 dLrXEq"><a href="#" data-component="FooterFAQLink" class="FooterNavListElement__ListElement-sc-1ulyhz1-0 eumMbs">FAQ</a></li><li class="FooterNavList__Item-vkkbkx-1 dLrXEq"><a href="https://www.legacy.com/privacy-policy/" data-component="FooterDoNotSellMyPersonalInformationLink" class="FooterNavListElement__ListElement-sc-1ulyhz1-0 eumMbs">Do Not Sell My Personal Information</a></li><li class="FooterNavList__Item-vkkbkx-1 dLrXEq"><a href="https://www.legacy.com/privacy-policy/" data-component="FooterPrivacyPolicyLink" class="FooterNavListElement__ListElement-sc-1ulyhz1-0 eumMbs">Privacy Policy</a></li><li class="FooterNavList__Item-vkkbkx-1 dLrXEq"><a href="https://www.legacy.com/terms-of-use/" data-component="FooterTermsofUseLink" class="FooterNavListElement__ListElement-sc-1ulyhz1-0 eumMbs">Terms of Use</a></li></ul><div class="FooterCopyrightLockUp__Container-sc-1017qdn-0 ecVthb"><svg width="101px" height="100%" viewBox="0 0 173 55" data-component="LegacyLogo"><path fill="#006699" fill-rule="evenodd" d="M7.78522869.371189202C8.61565723.371189202 9.42531292.350567785 10.21422.309324335 11.0031272.268080884 11.8543037.216527344 12.7677751.154662167 13.6812465.0927969911 14.4286209.0412434508 15.0099209 0 15.0929638.247460705 15.1344846.556781946 15.1344846.927973004 15.1344846 1.50538132 15.051443 1.79408114 14.8853573 1.79408114 14.470143 1.79408114 13.7227685 1.93843105 12.6432114 2.22713521 11.5636543 2.51583936 10.982363 2.80453919 10.8993202 3.09324335 10.5256273 4.53676412 10.3387837 6.45455582 10.3387837 8.84667597L10.3387837 32.1697308C10.3387837 34.3556337 10.5256273 36.1703183 10.8993202 37.6138391 11.0238844 38.0262736 12.4355918 38.2324878 15.1344846 38.2324878L18.1240124 38.2324878C21.9855051 38.2324878 24.6013158 37.8819237 25.9715229 37.180785 26.5943443 36.8508374 27.2898178 36.1187771 28.0579642 34.9845822 28.8261106 33.8503873 29.4385425 32.4996846 29.8952782 30.9324335 29.978321 30.6849728 30.2689667 30.5612443 30.7672238 30.5612443 31.5561309 30.5612443 32.075141 30.6849728 32.3242695 30.9324335 32.1166624 31.4685983 31.7948761 32.3243871 31.3589012 33.4998254 30.9229262 34.6752638 30.5803795 35.6238489 30.331251 36.3456093 30.0821224 37.0673697 29.8122372 37.9025371 29.5215872 38.8511364 29.2309372 39.7997358 29.0440936 40.5833496 28.9610507 41.2020014 26.8019365 41.2020014 23.4283711 41.1401371 18.8402534 41.0164068 14.2521357 40.8926764 10.5464039 40.8308122 7.72294686 40.8308122L.186845489 41.0164068C.0622812067 40.8926764 0 40.5627338 0 40.0265689 0 39.490404.0622812067 39.2223256.186845489 39.2223256.76814547 39.2223256 1.57780116 39.0985971 2.61583684 38.8511364 3.65387252 38.6036757 4.27668459 38.2943545 4.48429173 37.9231634 4.77494172 37.428242 4.92026453 35.4898289 4.92026453 32.1078659L4.92026453 8.72294624C4.92026453 6.08336538 4.77494172 4.20681652 4.48429173 3.09324335 4.35972744 2.76329574 3.76805598 2.46428521 2.70925958 2.19620278 1.65046319 1.92812035.851187702 1.79408114.311409148 1.79408114.145323438 1.79408114.0622818295 1.52600273.0622818295.989837871.0622818295.494916461.145323438.164973803.311409148 0 .851187702.0412434508 1.95148902.113418407 3.61234611.216527034 5.2732032.319635661 6.66415015.371189202 7.78522869.371189202zM45.2957664 16.27046C43.1366522 16.27046 41.4862002 17.188113 40.344361 19.0234466 39.2025217 20.8587801 38.6316107 22.3744542 38.6316107 23.5705143 38.6316107 23.8592185 38.7561731 24.0035684 39.0053016 24.0035684L51.1502584 24.0035684C51.3578655 24.0035684 51.4616675 23.7973542 51.4616675 23.3849197 51.4616675 22.0651293 50.9011367 20.5494552 49.7800581 18.837852 48.6589796 17.1262488 47.1642307 16.27046 45.2957664 16.27046zM45.9185847 13.9814599C47.8285704 13.9814599 49.510163 14.3423347 50.9634129 15.0640951 52.4166629 15.7858555 53.5273444 16.7138192 54.2954908 17.8480141 55.0636372 18.982209 55.6241681 20.1370083 55.9771002 21.3124467 56.3300323 22.487885 56.5064957 23.652995 56.5064957 24.8078116 56.5064957 25.6326807 56.3819333 26.1379053 56.1328048 26.3235009 55.8836762 26.5090964 55.4061869 26.6018928 54.7003227 26.6018928L39.0053016 26.6018928C38.6731302 26.6018928 38.507047 26.7049999 38.507047 26.9112171 38.507047 29.5095545 39.2959423 31.9016388 40.8737565 34.0875417 42.4515708 36.2734446 44.735215 37.3663796 47.7247578 37.3663796 48.5967077 37.3663796 49.4271238 37.283894 50.216031 37.1189202 51.0049381 36.9539463 51.6796511 36.7580429 52.2401904 36.5312039 52.8007297 36.3043649 53.2782189 36.0775294 53.6726725 35.8506904 54.0671261 35.6238514 54.4096727 35.4073265 54.7003227 35.2011093L55.1362955 34.8917849C55.3854241 34.8917849 55.5099865 35.1598634 55.5099865 35.6960282 55.5099865 36.0259758 55.3854241 36.3971613 55.1362955 36.8095958 54.3058669 37.9644124 53.0810032 39.005794 51.4616675 39.9337716 49.8423319 40.8617492 48.0776977 41.3257311 46.167712 41.3257311 42.7214336 41.3257311 39.7630763 40.0368926 37.2925513 37.4591769 34.8220264 34.8814612 33.5867825 31.7366953 33.5867825 28.0247847 33.5867825 23.6942224 34.7597452 20.2710673 37.1057058 17.7552168 39.4516665 15.2393663 42.3892634 13.9814599 45.9185847 13.9814599zM79.6110454 46.2130556C79.6110454 44.4808307 78.7598689 43.3157206 77.0574904 42.7176906 75.3551119 42.1196606 71.9711663 41.82065 66.9055522 41.82065 66.8225093 41.82065 66.6979469 41.8618929 66.5318612 41.9443798 66.4903398 41.9856232 66.3034961 42.0784196 65.9713247 42.2227717 65.6391533 42.3671237 65.4315493 42.4599201 65.3485064 42.5011636 65.2654636 42.542407 65.07862 42.6558248 64.78797 42.8414203 64.49732 43.0270159 64.3000962 43.1507444 64.1962926 43.2126095 64.092489 43.2744747 63.9160256 43.3982032 63.666897 43.5837987 63.4177685 43.7693943 63.2516853 43.9343656 63.1686424 44.0787177 63.0855995 44.2230698 62.9610371 44.3983518 62.7949514 44.604569 62.6288657 44.8107863 62.5146835 45.0170005 62.4524014 45.2232177 62.3901192 45.429435 62.327838 45.6665813 62.2655559 45.9346637 62.2032737 46.2027461 62.1721331 46.4811352 62.1721331 46.7698394 62.1721331 48.5433078 63.095971 49.9764962 64.9436745 51.0694476 66.7913781 52.1623991 68.8362777 52.7088666 71.0784348 52.7088666 73.5697204 52.7088666 75.61462 52.0489813 77.213195 50.7291909 78.8117699 49.4094004 79.6110454 47.9040371 79.6110454 46.2130556zM63.666897 22.6425413C63.666897 24.53974 64.2585685 26.1482105 65.4419292 27.4680009 66.6252899 28.7877913 68.0058566 29.4476767 69.5836708 29.4476767 71.2030065 29.4476767 72.5420525 28.8290342 73.6008488 27.5917306 74.6596452 26.3544271 75.1890355 24.8696852 75.1890355 23.1374602 75.1890355 21.2402615 74.597364 19.631791 73.4140034 18.3120006 72.2306427 16.9922102 70.8500759 16.3323249 69.2722617 16.3323249 67.652926 16.3323249 66.3138801 16.9509673 65.2550837 18.1882709 64.1962873 19.4255744 63.666897 20.9103164 63.666897 22.6425413zM69.521389 14.2289194C71.0576818 14.2289194 72.822316 14.4969978 74.8153445 15.0331627 76.808373 15.5693275 78.4484448 15.8374059 79.7356091 15.8374059L83.3479552 15.8374059C83.5970837 15.9198928 83.7216461 16.4354282 83.7216461 17.3840276 83.7216461 17.9614359 83.5970837 18.2501357 83.3479552 18.2501357L78.9259453 18.2501357C78.7598596 18.2501357 78.676818 18.312 78.676818 18.4357303L79.2996362 19.9204871C79.7563719 20.91033 79.9847364 21.9001579 79.9847364 22.8900008 79.9847364 25.1171471 78.9882371 27.1174245 76.9952086 28.8908929 75.00218 30.6643612 72.5524526 31.5510821 69.6459527 31.5510821 68.317267 31.5510821 67.1546845 31.4685965 66.1581702 31.3036227 65.6183917 31.5923268 65.0474806 32.1078622 64.4454199 32.8502443 63.8433592 33.5926264 63.5423334 34.2525118 63.5423334 34.8299201 63.5423334 35.4073284 63.7084166 35.8713102 64.040588 36.2218796 64.3727594 36.5724489 64.8502487 36.8199059 65.4730701 36.964258 66.0958915 37.1086101 66.6979432 37.2117171 67.2792432 37.2735823 67.8605431 37.3354475 68.5456364 37.3663796 69.3345435 37.3663796L69.7705163 37.3663796C74.9191733 37.4488665 78.5314833 37.9747126 80.6075547 38.9439337 82.683626 39.9131548 83.7216461 41.3669647 83.7216461 43.3054068 83.7216461 46.4811526 82.37222 49.2134902 79.6733272 51.5025017 76.9744345 53.7915132 73.5074473 54.9566232 69.2722617 54.9978667 66.3242404 55.0391101 63.6772891 54.4823319 61.3313284 53.3275153 58.9853678 52.1726987 57.8124051 50.4404997 57.8124051 48.1308665 57.8124051 45.5737725 59.8469245 43.3879024 63.9160244 41.5731906 62.7949458 41.4082168 61.7569257 40.8926814 60.8019329 40.0265689 59.8469401 39.1604564 59.3694508 38.1087642 59.3694508 36.8714607 59.3694508 35.799131 59.8365599 34.6855745 60.770792 33.5307579 61.7050241 32.3759412 62.7534244 31.4273561 63.9160244 30.684974 62.6703815 30.231296 61.5181792 29.2517788 60.4593828 27.7463928 59.4005864 26.2410069 58.8711962 24.6222257 58.8711962 22.8900008 58.8711962 20.4566372 59.8988361 18.4048063 61.9541467 16.7344465 64.0094574 15.0640867 66.5318462 14.2289194 69.521389 14.2289194zM92.1899659 36.964258C92.8958301 37.562288 93.8092878 37.8612986 94.9303664 37.8612986 96.0514449 37.8612986 97.1309858 37.5210452 98.1690215 36.8405282 99.2070572 36.1600113 99.7260672 35.4691939 99.7260672 34.7680552L99.7260672 28.3959739C99.3938958 28.5609477 98.5842401 28.8496475 97.2970759 29.2620821 96.0099116 29.6745166 95.0030321 30.0353913 94.2764072 30.3447172 93.5497822 30.6540431 92.8439285 31.1695785 92.1588249 31.8913389 91.4737214 32.6130993 91.1311748 33.4482666 91.1311748 34.396866 91.1311748 35.5104392 91.4841016 36.3662279 92.1899659 36.964258zM98.0444578 13.9814599C100.328136 13.9814599 101.968208 14.5279274 102.964722 15.6208789 103.961237 16.7138303 104.459486 18.4769614 104.459486 20.910325L104.459486 35.2011093C104.459486 36.0672217 104.687851 36.7889713 105.144586 37.3663796 105.601322 37.9437879 106.224134 38.2324878 107.013041 38.2324878 107.594341 38.2324878 108.320955 37.9437879 109.192905 37.3663796 109.358991 37.3663796 109.442033 37.5313509 109.442033 37.8612986 109.442033 38.3974634 109.338231 38.8305132 109.130623 39.1604608 107.428245 40.6039815 105.975017 41.3257311 104.770895 41.3257311 103.815903 41.3257311 102.902445 40.9339242 102.030495 40.1502986 101.158545 39.3666731 100.556493 38.5418164 100.224322 37.675704 100.1828 37.675704 100.027097 37.8097432 99.7572082 38.0778256 99.4873189 38.345908 99.1240118 38.6552293 98.6672761 39.0057986 98.2105404 39.3563679 97.6811502 39.7172427 97.0790895 40.0884338 96.4770288 40.4596248 95.7711751 40.7689461 94.9615073 41.0164068 94.1518394 41.2638675 93.3318036 41.387596 92.501375 41.387596 90.5913894 41.387596 89.0135988 40.8823713 87.767956 39.8719067 86.5223132 38.8614422 85.8995011 37.3457681 85.8995011 35.324839 85.8995011 34.4174831 86.1278655 33.5616943 86.5846012 32.757447 87.0413369 31.9531997 87.5811074 31.2933144 88.2039288 30.7777713 88.8267502 30.2622282 89.6779267 29.736382 90.7574838 29.2002172 91.8370409 28.6640523 92.7608788 28.2619347 93.5290252 27.9938523 94.2971716 27.7257698 95.3040511 27.3855165 96.5496939 26.973082 97.7953367 26.5606475 98.6672736 26.2513262 99.1655308 26.045109 99.5392236 25.9213786 99.7260672 25.6120574 99.7260672 25.117136L99.7260672 20.4772709C99.7260672 19.1574805 99.3108592 18.1367204 98.4804306 17.41496 97.6500021 16.6931996 96.6535028 16.3323249 95.4909028 16.3323249 94.24526 16.3323249 93.2072399 16.7550639 92.3768114 17.6005546 91.5463828 18.4460454 91.1311748 19.5492911 91.1311748 20.910325 91.1311748 22.3538458 90.2799983 23.0755954 88.5776198 23.0755954 87.4150198 23.0755954 86.6053641 22.6837885 86.1486284 21.9001629 86.1486284 20.1266945 87.4565337 18.3635634 90.0723837 16.6107168 92.6882336 14.8578701 95.3455651 13.9814599 98.0444578 13.9814599zM122.145517 13.9814599C126.712874 13.9814599 129.868455 15.0331521 131.612355 17.1365681 131.612355 19.8998793 130.84422 21.2815142 129.307927 21.2815142 128.602063 21.2815142 128.062292 21.1268536 127.6886 20.8175277 127.314907 20.5082018 126.837417 19.9411129 126.256118 19.1162439 124.968953 17.2190451 123.432684 16.27046 121.647262 16.27046 119.944884 16.27046 118.398234 17.0746952 117.007266 18.6831898 115.616298 20.2916844 114.920825 22.6837687 114.920825 25.8595144 114.920825 29.1589904 115.74086 31.9016388 117.380957 34.0875417 119.021053 36.2734446 121.294317 37.3663796 124.200817 37.3663796 125.072767 37.3663796 125.903183 37.283894 126.69209 37.1189202 127.480997 36.9539463 128.155711 36.7580429 128.71625 36.5312039 129.276789 36.3043649 129.754278 36.0775294 130.148732 35.8506904 130.543185 35.6238514 130.885732 35.4073265 131.176382 35.2011093L131.612355 34.8917849C131.861483 34.8917849 131.986046 35.1598634 131.986046 35.6960282 131.986046 36.0259758 131.861483 36.3971613 131.612355 36.8095958 130.781926 37.9644124 129.557063 39.005794 127.937727 39.9337716 126.318391 40.8617492 124.553757 41.3257311 122.643771 41.3257311 119.197493 41.3257311 116.239136 40.0368926 113.768611 37.4591769 111.298086 34.8814612 110.062842 31.7366953 110.062842 28.0247847 110.062842 24.2303872 111.100862 20.9412714 113.176933 18.1573384 115.253005 15.3734055 118.242503 13.9814599 122.145517 13.9814599zM140.082684 14.414514C140.788548 14.414514 141.442501 14.3938926 142.044561 14.3526491 142.646622 14.3114057 143.331715 14.2701628 144.099862 14.2289194 144.868008 14.1876759 145.542721 14.1464331 146.124021 14.1051897 146.207064 14.3526504 146.248585 14.6619716 146.248585 15.0331627 146.248585 15.610571 146.165543 15.8992708 145.999457 15.8992708 145.667286 15.8992708 145.117135 16.0436207 144.348989 16.3323249 143.580843 16.621029 143.155254 16.9097288 143.072211 17.198433L143.072211 17.3221627C143.072211 18.0645449 145.293575 23.4467345 149.736367 33.468893L154.469786 19.9204871C154.760436 19.0543747 154.905759 18.4151108 154.905759 18.0026763 154.905759 17.3840245 154.583973 16.8787998 153.940391 16.486987 153.296809 16.0951743 152.435252 15.8992708 151.355695 15.8992708 151.189609 15.8992708 151.106567 15.6311924 151.106567 15.0950275 151.106567 14.6001061 151.189609 14.2701635 151.355695 14.1051897L153.784686 14.2907843C154.864243 14.3732712 155.902263 14.414514 156.898778 14.414514 157.812249 14.414514 158.808748 14.3732712 159.888305 14.2907843L162.317297 14.1051897C162.40034 14.3526504 162.44186 14.6619716 162.44186 15.0331627 162.44186 15.610571 162.358819 15.8992708 162.192733 15.8992708 161.652955 15.8992708 160.91596 16.0848635 159.981728 16.4560546 159.047496 16.8272457 158.435064 17.4252667 158.144414 18.2501357L146.995967 48.1308665C146.040974 50.6879604 144.961433 52.4717129 143.757312 53.4821774 142.55319 54.492642 141.452889 54.9978667 140.456375 54.9978667 139.584425 54.9978667 138.940852 54.7297883 138.525638 54.1936234 138.110424 53.6574586 137.90282 53.1213017 137.90282 52.5851369 137.90282 51.677781 138.193465 51.0178956 138.774765 50.6054611 142.221044 50.6054611 144.504688 48.8320194 145.625766 45.2850826L146.373148 43.0579474C146.663798 42.1918349 146.892163 41.4907068 147.058249 40.9545419L138.151947 19.3018385C137.695211 18.3119957 137.280003 17.6108675 136.90631 17.198433 136.532618 16.8272419 135.961706 16.5179207 135.19356 16.27046 134.425414 16.0229993 133.812982 15.8992708 133.356246 15.8992708 133.19016 15.8992708 133.107119 15.6311924 133.107119 15.0950275 133.107119 14.6001061 133.19016 14.2701635 133.356246 14.1051897 137.632953 14.3114069 139.875077 14.414514 140.082684 14.414514zM168.107527 10.2351112L168.679026 10.2351112C168.98859 10.2351112 169.231815 10.1559679 169.408709 9.99767906 169.585602 9.83939019 169.674048 9.60876848 169.674048 9.30580699 169.674048 8.72030839 169.338975 8.42756348 168.668821 8.42756348L168.107527 8.42756348 168.107527 10.2351112zM170.204725 9.28027666C170.204725 9.54919753 170.139242 9.78662726 170.008273 9.99257299 169.877303 10.1985187 169.689357 10.3593582 169.444427 10.4750963L170.653761 12.4817806 170.036337 12.4817806 168.964776 10.6435965 168.107527 10.6435965 168.107527 12.4817806 167.592157 12.4817806 167.592157 7.98844172 168.668821 7.98844172C169.155278 7.98844172 169.532872 8.09396605 169.801614 8.30501787 170.070356 8.51606969 170.204725 8.8411527 170.204725 9.28027666zM165 10.2351112C165 9.55429884 165.170087 8.91604686 165.510267 8.32033607 165.850447 7.72462528 166.318187 7.25487182 166.913502 6.9110616 167.508817 6.56725137 168.150046 6.39534884 168.837209 6.39534884 169.517569 6.39534884 170.155397 6.56554937 170.750711 6.90595553 171.346026 7.2463617 171.815467 7.71441315 172.159049 8.31012394 172.50263 8.90583473 172.674419 9.54749072 172.674419 10.2351112 172.674419 10.9057113 172.509434 11.5354533 172.179459 12.1243559 171.849485 12.7132586 171.386847 13.1847141 170.791533 13.5387365 170.196218 13.8927589 169.544783 14.0697674 168.837209 14.0697674 168.133037 14.0697674 167.483303 13.8936099 166.887989 13.5412895 166.292674 13.1889691 165.829186 12.7183647 165.497511 12.129462 165.165835 11.5405593 165 10.9091154 165 10.2351112zM165.474548 10.2351112C165.474548 10.8410341 165.625076 11.4018449 165.926135 11.9175602 166.227194 12.4332756 166.636254 12.8426078 167.153328 13.1455693 167.670401 13.4485308 168.231689 13.6000093 168.837209 13.6000093 169.442729 13.6000093 170.003167 13.4493818 170.51854 13.1481224 171.033912 12.8468629 171.442972 12.4375306 171.745732 11.9201133 172.048492 11.4026959 172.19987 10.8410341 172.19987 10.2351112 172.19987 9.64280445 172.054445 9.08965273 171.763592 8.57563942 171.472738 8.06162611 171.066229 7.64803882 170.544053 7.33486515 170.021877 7.02169148 169.452935 6.865107 168.837209 6.865107 168.238493 6.865107 167.679756 7.01573446 167.160982 7.31699392 166.642207 7.61825337 166.231446 8.03098966 165.928686 8.55521515 165.625926 9.07944064 165.474548 9.63940039 165.474548 10.2351112z"></path></svg><p data-component="FooterCopyrightText" class="FooterCopyrightStatement__CopyrightStatement-n6gizp-0 eXdSuC">©<!-- -->2022 Legacy.com All rights reserved.</p></div></footer><div id="overlay-display-overlay-1" width="100%" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 bRNFSA"><div height="20px" width="20px" display="flex" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 xVSJr"><svg width="12px" height="100%" viewBox="0 0 24 24"><g fill="none" fill-rule="evenodd"><rect width="24" height="24"></rect><path fill="#404F57" d="M21.556314,2.45885476 C20.9647327,1.86727342 20.0091013,1.86727342 19.4175199,2.45885476 L12,9.86120592 L4.58248009,2.44368601 C3.99089875,1.85210466 3.03526735,1.85210466 2.44368601,2.44368601 C1.85210466,3.03526735 1.85210466,3.99089875 2.44368601,4.58248009 L9.86120592,12 L2.44368601,19.4175199 C1.85210466,20.0091013 1.85210466,20.9647327 2.44368601,21.556314 C3.03526735,22.1478953 3.99089875,22.1478953 4.58248009,21.556314 L12,14.1387941 L19.4175199,21.556314 C20.0091013,22.1478953 20.9647327,22.1478953 21.556314,21.556314 C22.1478953,20.9647327 22.1478953,20.0091013 21.556314,19.4175199 L14.1387941,12 L21.556314,4.58248009 C22.1327266,4.0060675 22.1327266,3.03526735 21.556314,2.45885476 Z"></path></g></svg></div><div display="flex" id="display-overlay-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 dtUqX"></div></div><div display="flex" id="custom-overlay-1" opacity="1" class="Box-sc-5gsflb-0 Flex-sc-1v9q3u-0 AdSlot__StandardAd-sc-14i9nnh-0 dtUqX"></div></body></div>
<script type="application/json" data-hypernova-key="ObituaryPage" data-hypernova-id="d812ce1f-bdd3-4196-b0e0-296a5ef0bdd7">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</script>
    <script type="text/javascript" src="/static/993b50c/bundle.js"></script>
    </html>

</html>
